Inicio > Curiosidades y varios > Un problema de TimThumb hace WordPress vulnerable a ataques

Un problema de TimThumb hace WordPress vulnerable a ataques

WordPress HackedYa lo veníamos avisando desde hace tiempo, pero ahora por primera vez se ha dado un caso a gran escala de uso de una vulnerabilidad de un plugin/addon de WordPress. En este caso los blogs afectados son los que usan TimThumb usado para redimensionar imágenes.

El problema principal en este caso es el elevado número de temas de WordPress que usan este addon en su código (dentro del propio tema) sin que muchas veces el administrador de la web sea consciente que lo tiene instalado en el servidor.

El uso de plugins/addons en los temas que nunca más se actualizan es justamente uno de los principales problemas que detectamos en muchas instalaciones de WordPress; además claro de que no se actualice la versión de WordPress ni de los plugins.

WordPress no controla de ninguna forma el código de los temas personalizados y por tanto tampoco si se actualiza el código de terceros que hayamos incluido en el mismo. En conclusión, si el tema está programado o personalizado por nosotros, nunca se nos avisará por parte de WordPress de la necesidad de una actualización o de una vulnerabilidad.

ATENCIÓN: Solo en muy rara ocasión un programador actualiza los componentes de terceros inlcuidos en temas que haya programado/personalizado. A esto se le debería de prestar mucha más atención y sobre todo tratar de utilizar siempre las funciones incluidas en WordPress, ya que estas si que se van actualizando periódicamente o plugins en su correspondiente carpeta que normalmente también se van actualizando.

Se ha publicado un listado de los temas que usan TimThumb disponibles en el directorio de temas gratuitos de WordPress. Muy interesante consultarlo si se ha utilizado un tema del mismo.

También podemos buscar dentro de los temas por los archivos “timthumb.php” o “thumb.php“. Si estos existen hay que ver que versión tienen, ya que a partir de la versión 2.0 del plugin esta vulnerabilidad está solucionada.

El primer aviso de esta vulnerabilidad se produjo en verano por parte del blog de securi.net: “Timthumb.php Security Vulnerability – Just the Tip of the Iceberg” donde se explicaba como usar TimThumb para subir cualquier archivo a un servidor que lo tuviese instalado. Hay más detalles aquí.

Ahora en octubre el fabricante de antivirus AVAST ha publicado que ha bloqueado 2500 webs en septiembre y otras tantas en octubre por estar infectadas con Blackhole a través de la vulnerabilidad de TimThumb.

Blackhole es una herramienta profesional (y de pago) que aprovecha exploits (agujeros de seguridad), para obtenter acceso a sistemas informáticos y poder manejarlos libremente (por ejemplo para el envío de spam u otros ciberdelitos).

Exploit (del inglés to exploit, explotar o aprovechar) es un software que permite el aprovechamiento automatizado de un error, fallo o vulnerabilidad para poder acceder al sistema informático de forma no autorizada y emplearlo en beneficio propio o como origen de otros ataques a terceros.

Exploit: Término con el que se denomina en el entorno “hacker” a un método concreto de usar un error de algún programa o sistema operativo (bug) para entrar en un sistema informático y obtener los privilegios del administrador para tener un control total sobre el sistema.

Black Hole Exploits Kit: Paquete de exploits pre-compilado que está destinado a facilitar las maniobras delictivas a través de Internet. Es una aplicación web desarrollada en Rusia pero que además incorpora para su interfaz el idioma inglés, y cuya primera versión está intentando insertarse en el mercado clandestino desde principios de septiembre de 2010.

 

A la vista de todos estos problemas, queremos volver a recalcar lo importante que es actualizar la versión de WordPress, los plugins y también os recomendamos revisar y actualizar el código de vuestros temas.

Tampoco está de más utilizar algún plugin de seguridad para WordPress:  WP Security Scan y/o Exploit Scanner.

Descubre porqué somos Apasionados del Marketing

Mira también

Link Privacy: Bloquea herramientas de monitorización de enlaces entrantes (backlinks)

Cómo impedir a los bots acceder a tu sitio WordPress

Últimamente me han preguntado varias personas como puede ser que haya determinadas páginas web bien …